OLP payments slow system responses and/or errors
Incident Report for Click & Drop
Resolved
This incident has now been resolved.
Posted May 08, 2024 - 13:43 BST
Monitoring
The third party has now resolved the issue and we are monitoring the system. We once again apologise for any inconvenience this has caused.
Posted May 08, 2024 - 10:52 BST
Investigating
We are aware that some of you are experiencing slower system responses and occasional errors while making payments using PayPal/debit/credit card in Click and Drop. Our technical team have identified that this is due to a third party system Click & Drop uses, and we have contacted the third party to investigate the problem urgently. Please note that this issue does not affect OBA users.

We understand how crucial our services are to your operations and are committed to ensuring a seamless experience. In the meantime, we ask for your patience and apologise for any inconvenience caused.
Posted May 08, 2024 - 09:14 BST
This incident affected: Website (Click & Drop Payment Processing (Personal Customers)).