Some customers are reporting slow system response and/or errors
Incident Report for Click & Drop
Resolved
This incident has now been resolved. We apologise for any disruption and inconvenience this may has caused.
Posted May 07, 2024 - 11:33 BST
Monitoring
A fix has now been implemented and we are now monitoring system performance
Posted May 07, 2024 - 10:57 BST
Update
We are continuing to investigate this issue and apologise again for the inconvenience caused
Posted May 07, 2024 - 10:44 BST
Investigating
We are aware that some of you are experiencing slower system responses and errors while using the Click and Drop application. Our technical team is actively investigating these issues to understand and resolve them quickly.

We understand how crucial our services are to your operations and are committed to ensuring a seamless experience. In the meantime, we ask for your patience and apologise for any inconvenience caused.
Posted May 07, 2024 - 10:22 BST
This incident affected: Website (Click & Drop website (Registered)).